Imbogamizi mu gusaba serivisi ku rubuga IremboGov - IremboGov is currently facing a technical interruption when applying for the services

Incident Report for IremboGov

Resolved

Ikibazo twari twagize mu gusaba Serivisi ku rubuga IremboGov cyakemutse. Mwakoze kwihangana mugihe twarimo ducyemura ikibazo.

The issue we faced in applying for the services on IremboGov is now resolved. We thank you for your patience while we were working on the issue.
Posted Dec 09, 2025 - 14:10 CAT

Investigating

Ku bakoresha IremboGov,
Turabamenyesha ko urubuga rw’ IremboGov ruri kugenda gahoro. Turabasaba kwihangana mugihe turi gukemura iki kibazo.
Turabamenyesha nigikemuka

Murakoze.

Dear IremboGov Users,
We would like to inform you that the IremboGov platform is currently experiencing slow performance. Kindly bear with us as our team works to resolve the issue. We will provide updates as soon as it is resolved.

Thank you!
Posted Dec 09, 2025 - 13:33 CAT
This incident affected: IremboGov Website (RNP, DGIE, DGIE - Visa on arrival and overstay penalties, NIDA, MINALOC, RLMUA, RSSB, RURA, REB, NPPA, MUSEUMS (INMR), NOTARY, MINIJUST (Gazette), MHC, NESA, RGB, HEC, Applications Finder, Login, RBC, Sign up, RCHA, RIB, MINICOM, Government officers portal).