Imbogamizi mu Kwandikisha aderesi ya ePoBox, Technical interruption in applying for ePoBox registration

Incident Report for IremboGov

Resolved

Ku bakoresha IremboGov,
Imbogamizi zari muri serivisi yo Kwandikisha aderesi ya ePoBox ku rubuga IremboGov zakemutse, kandi serivisi iraboneka nk'uko bisanzwe.

Mwakoze kwihangana.


Dear IremboGov Users,
The technical issue affecting the Register an ePoBox Address service on the IremboGov platform has been resolved. The service is now available.

Thank you for your patience.
Posted Mar 20, 2026 - 15:56 CAT

Investigating

Ku bakoresha IremboGov,
Turabamenyesha ko hari imbogamizi mu gusaba serivisi yo Kwandikisha aderesi ya ePoBox unyuze ku rubuga IremboGov.
Turi kubikurikirana kandi turabamenyesha nibikemuka.

Murakoze.


Dear IremboGov Users,
Please be advised that there is a technical interruption affecting the Register an ePoBox Address service on the IremboGov platform.
We are investigating the matter and will update you once it's resolved.

Thank you.
Posted Mar 19, 2026 - 11:46 CAT
This incident affected: Upgraded IremboGov Website (E-POBOX).