Please note that the technical interruption that had made applying for birth certificates using ChildIDs unavailable has been resolved.
We thank you for your patience.
Posted Mar 06, 2026 - 13:31 CAT
Investigating
Ku bakoresha IremboGov, Turabamenyesha ko gusaba icyemezo cy'amavuko hakoreshejwe nimero y'ifishi y'umwenegihugu ku rubuga IremboGov bitari gukunda. Tubasabye kwihangana mu gihe turi kubikemura.
Murakoze.
Dear IremboGov users, Please note that applying for birth certificates using ChildIDs is currently unavailable on IremboGov. We apologize for any inconvenience this might cause as we work to resolve the issue.
Thanks.
Posted Mar 06, 2026 - 12:52 CAT
This incident affected: IremboGov Website (MINALOC).