Imbogamizi mu gusaba serivisi zisabwa hakoreshejwe nomero y’indagamuntu cyangwa nomero y’ifishi - Technical interruption in applying for the services that require a National Identification Card or Child Identification number.

Incident Report for IremboGov

Update

We are continuing to investigate this issue.
Posted Jun 07, 2026 - 17:05 CAT

Update

We are continuing to investigate this issue.
Posted Jun 06, 2026 - 08:33 CAT

Investigating

Ku bakoresha IremboGov,

Kubera igikorwa cyo kuvugurura sisitemu y'umufatanyabikorwa wacu NIDA, hari imbogamizi mu kubona amakuru ya nomero y’indagamuntu cyangwa nomero y’ifishi igihe musaba serivisi zikenera aya makuru ku rubuga IremboGov.

Murakoze kwihangana, nibikemuka turabamenyesha!



Dear IremboGov users,

Due to an ongoing system maintenance by our partner NIDA, users are unable to get National Identification or Child Identification details while applying for services that require this information on the IremboGov platform.

We will share an update once the maintenance is complete.

Thank you for your patience

Thank you!
Posted Jun 06, 2026 - 08:32 CAT
This incident affects: IremboGov Website (RSSB, RLMUA, MINALOC, NIDA, NPPA, DGIE).