Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 06, 2026 - 21:00 CAT
Update
We will be undergoing scheduled maintenance during this time.
Posted Aug 06, 2026 - 19:46 CAT
Scheduled
Ku bakoresha IremboGov,
Turabamenyesha ko haza kubaho igikorwa cyo kuvugurura no kunoza serivisi z'Ikigo cy'Ubwiteganyirize mu Rwanda(RSSB). Iki gikorwa giteganyijwe uyu munsi, tariki 06 Kanama 2026, guhera saa tatu z'ijoro (21:00) kugeza saa sita z'ijoro (00:00). Muri iki gihe, hashobora kubaho imbogamizi mu gusaba serivisi yo Kwishyura Mituweli ku rubuga IremboGov.
Tubiseguyeho ku mbogamizi bishobora guteza. Turabamenyesha iki gikorwa nigisozwa.
Murakoze!
Dear IremboGov users,
We would like to inform you that there is a scheduled system maintenance by the Rwanda Social Security Board(RSSB) tonight, 06th August 2026, from 21:00 PM to 12:00AM. During this time, paying for Community Based Health Insurance(Mutuelle) on IremboGov may be temporarily unavailable.
We apologize for any inconvenience this may cause. We will update you once this maintenance is completed.
Thank you!
Posted Aug 06, 2026 - 19:46 CAT
This scheduled maintenance affected: IremboGov Website (RSSB).