Ubutinde mu gukurura amakuru y'indangamuntu ku rubuga IremboGov, Potential slowness in applying for services that require National ID information on IremboGov

Incident Report for IremboGov

Update

We are continuing to investigate this issue.
Posted Feb 26, 2026 - 16:21 CAT

Investigating

Ku bakoresha IremboGov,
Turabamenyesha ko kubona amakuru y'indangamuntu mu gusaba serivisi ziyakenera ku rubuga IremboGov bitari gukunda. Muri iki gihe, gusaba izo serivisi bishobora kudakunda.
Tubasabye kwihangana mu gihe turi kubikurikirana.

Murakoze.

Dear IremboGov users,
Please note that fetching national ID information on IremboGov is now unavailable. As a result, you may experience difficulty when applying for services that require this information.
We are working with our partners to resolve the issue as quickly as possible.

Thank you!
Posted Feb 26, 2026 - 11:21 CAT
This incident affects: IremboGov Website (DGIE, DGIE - Visa on arrival and overstay penalties, NIDA, MINALOC, RLMUA, RSSB, NPPA, Login, Sign up).