Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 27, 2025 - 23:30 CAT
Update
We will be undergoing scheduled maintenance during this time.
Posted Mar 27, 2025 - 22:36 CAT
Scheduled
Ku bakoresha IremboGov, Turabamenyesha ko haza kubaho igikorwa cyo kuvugurura serivisi za SMS Iki gikorwa giteganyijwe taliki 27 werurwe 2025, guhera saa tanu n'igice z’ijoro kugeza saa sita n'igice za mu gitondo. Tubiseguyeho kumbogamizi bishobora guteza
Dear IremboGov Users, We would like to inform you that our SMS will undergo a scheduled maintenance tonight, March 27th, 2025, from 23:30 AM up to March 28th 12:30 AM. We apologize for any inconvenience might cause.
Thank you
Posted Mar 27, 2025 - 22:36 CAT
This scheduled maintenance affected: Notifications (SMS).