Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 16, 2026 - 02:00 CAT
Scheduled
Ku bakoresha IremboGov,
Turabamenyesha ko hateganyijwe igikorwa cy’ivugurura ya sistemu z’umufatanyabikorwa wacu, MTN MoMo kuwa 16 Kamena 2026 saa munani z’ijoro (02:00), kugeza saa kumi n'imwe z'igitondo (05:00).
Muri iki gihe, kwishyura serivisi ku rubuga IremboGov hakoreshejwe MoMo Push (*182*7# → Kwemeza kwishyura) na MoMo Pull (*182*3# → Kwishyura) bishobora kudakunda; serivisi zitishyurwa zo zirakomeza kuboneka nk'uko bisanzwe.
Mushobora kwishyura mukoresheje indi miyoboro ari yo;
Amakarita (Visa, Mastercard, American Express) Airtel Money I&M Bank Banki ya Kigali (BK App)
Murakoze
Dear IremboGov users,
This is to inform you that our partner, MTN MoMo, will conduct a system maintenance activity on June 16th, 2026, from 02:00 AM to 05:00 AM.
During this time, paying for services on IremboGov that require payment using MTN MoMo Push (*182*7# → CashOut Approval) and MTN MoMo Pull (*182*3# → Pay Bill) may be temporarily unavailable. Services that do not require payment will remain unaffected.
In the meantime, you can use alternative payment channels, such as:
Cards (Visa, Mastercard, American Express) Airtel Money I&M Bank Bank of Kigali (BK App)
Thank you.
Posted Jun 15, 2026 - 15:59 CAT
This scheduled maintenance affected: Payments (MTN Mobile Money).