Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 07, 2025 - 20:02 CAT
Scheduled
Ku bakoresha IremboGov
Turabamenyesha ko haza kubaho igikorwa cyo kuvugurura urubuga IremboPay. Iki gikorwa giteganyijwe none taliki 7 Nyakanga 2025, guhera saa mbili z’ijoro (20:00) kugeza saa kumi n’imwe (5:00) za mugitondo. Muri iki gihe kwishyura serivisi no kwakira ubutumwa bwa kode yo kwishyuriraho ntibiza gukunda.
Tubiseguyeho ku mbogamizi bishobora gutera.
Murakoze.
Dear IremboGov Users,
We would like to inform you that our payment platform IremboPay, will undergo a scheduled maintenance tonight, July 7th 2025, from 8:00 PM to 5:00 AM. During this time generating bill IDs and paying for services on the IremboGov platform will temporarily not be available.
We apologize for any inconvenience this may cause.
Thank you
Posted Jul 07, 2025 - 20:01 CAT
This scheduled maintenance affected: Payments (Airtel money, MTN Mobile Money, Online payments, BK Channels, I&M Channels).