Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 11, 2026 - 01:00 CAT
Scheduled
Ku bakoresha IremboGov,
Turabamenyesha ko haza kubaho igikorwa cy’ivugurura ya sistemu z’umufatanyabikorwa wacu, MoMo Rwanda, taliki 11 Gashyantare 2026, guhera saa saba z’ijoro (01:00) kugeza saa kumi n’imwe za mu gitondo (05:00). Muri iki gihe, kwishyura serivisi zishyurwa ku rubuga IremboGov hakoreshejwe MoMo Push (*182*7# → Kwemeza kwishyura) na MoMo Pull (*182*3# → Kwishyura) bishobora kudakunda; serivisi zitishyurwa zo zirakomeza kuboneka nk'uko bisanzwe.
Mwakoresha indi miyoboro ariyo; - Amakarita (Visa, Mastercard, American Express) - Airtel Monay - I&M Bank - Banki ya Kigali (BK App)
Tubiseguyeho ku mbogamizi bishobora gutera.
Murakoze
Dear IremboGov users,
This is to inform you that our partner’s platform, MoMo Rwanda, will undergo a scheduled system maintenance activity tonight, Wednesday, February 11th, 2026, from 01:00 AM to 05:00 AM. During this time, paying for services on IremboGov that require payment using MTN MoMo Push (*182*7# → CashOut Approval) and MTN MoMo Pull (*182*3# → Pay Bill) may be temporarily unavailable. Services that do not require payment will remain accessible. In the meantime, you can use alternative payment channels, such as: - Cards (Visa, Mastercard, American Express) - Airtel Money - I&M Bank - Bank of Kigali (BK App)
We apologize for any inconvenience this may cause.
Thank you
Posted Feb 10, 2026 - 17:45 CAT
This scheduled maintenance affected: Payments (MTN Mobile Money).